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C# Express  
  

  .תלמידים ומפתחים חובבים ,מייקרוסופט פיתחה סדרת כלי פיתוח חינמיים עבור סטודנטים
המתקדמות מבעלי תכונות הם ואם זאת קלי משקל ופשוטים לשימוש וללמידה פיתוח אלו כלי 

  .שוק כלי הפיתוחבביותר 
   .C#מבין כלי הפיתוח החינמיים השונים אותנו מעניין כלי הפיתוח ללימוד ותרגול שפת 

   .C# Expressכלי הפיתוח נקרא 
  

   C# Expressהתקנת 
  : ומורכת משלושה שלבים היא קלה ופשוטהC# Expressהתקנת 
  .רישום, התקנה , הורדה 

  
  :להתקנהבדרישות המינימאליות  לפני ההתקנה כדאי לבדוק האם המחשב עומד אולם

 או                            Windows 2000 Service Pack 4:  מערכת הפעלה  •
Windows XP Service Pack 2. 

  .1GHz רצוי 600MHzמינימום : מעבד  •

   .512M רצוי 256Mמינימום  : זיכרון •

  . להתקנה מלאה1.3G: מקום פנוי בדיסק הקשיח  •
   

   C# Expressהורדת  -שלב ראשון 
  

  : בכתובת ,  מהאתר מיקרוסופט C# Expressניתן להוריד את 
visualcsharp/express/studiov/com.microsoft.msdn://http 

  

  
  . של החלוןהימניבצידו  " Download Now"יש ללחוץ , על מנת להתחיל את תהליך ההורדה 

 י להורדה/לחץ
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  :הלחיצה מובילה אותנו לחלון הבא 

  
  

  :חלון זה מציג שלושה שלבים
סביר . טהסרה מוחלטת של גרסאות קודמות של כלי הפיתוח החינמיים של מיקרוסופ .1

 או כלי פיתוח חינמיים C# Expressניח שלא התקנתם גרסאות קודמות של מאוד לה
 . ולכן שלב זה מיותר לכם וניתן לדלג עליוExpressאחרים מסדרת 

 או כל כלי פיתוח אחר C# Expressבמידה ומותקנות אצלכם גרסאות קודמות של 
אשר " uninstall any pervious versions" לחצו על הקישור Express -מסדרת ה

  .יוביל אתכם להורדת כלי להסרה מוחלטת שלהם
 : מתחיל בהורדת קובץ ההתקנה" Download"הקישור  .2

  
 ולשמור את הקובץ בדיסק Saveאו ,  להרצה מיד לאחר ההורדהRunניתן ללחוץ על 

  .להרצה במועד אחר) vcssetup.exeשם הקובץ הינו (הקשיח 
חינמי לחלוטין אולם מייקרוסופט דורשת  הוא כלי C# Expressאמנם , רישום התוכנית .3

 . יום30- במידה ותבחרו שלא לבצע רישום הוא יפסיק לעבוד לאחר כ, לבצע רישום
ההתקנה דרך כלי לאחר בסיום ההתקנה על ידי תוכנת ההתקנה או מתבצע הרישום 

  .הפיתוח עצמו

 הסרה של – 1שלב 
 גרסאות קודמות 

 #C הורדת –2שלב 
Express.   

 הסבר על –2שלב 
  .רישום התוכנה
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   C# Express התקנת –שלב שני 

תחילה מציג קובץ ההתקנה מספר חלונות , תהליך פשוט בן מספר שלביםנה יההתקנה ה
  .)ניתן להתעלם ממידע זה (ו על טעינת קבצי ההתקנה למחשבנקטנים ובו הוא מספר ל

המכיל דברי הסבר קצרים על תהליך " Welcome to Setup"מיד לאחר מכן נפתח חלון 
  . על מנת לעבור לחלון הבאNextלוחצים על הלחצן , ההתקנה

  

  
  

מספק לכם פרטים על תנאי הרישיון בכלי " End-User License Agreement "- חלון ה
  .לפני שנוכל להמשיך להתקדם בהתקנה יש לאשר שאנו מסכימים לתנאי הרישיון, הפיתוח

  
  

 ומעבר Nextלחיצה על 
  .לחלון הבא

יש לאשר את תנאי 
הרישיון לפני המעבר 

  .לשלב הבא
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מאפשר להוסיף להתקנה מסד נתונים " Installation Options "- חלון ה, החלון הבא שנפתח
מסד נתונים זה נדרש רק לתלמידי מגמת  , SQL Server 2005 Express Editionהנקרא 

Web Services ,  מומלץ לתלמידיWeb Services  למרות שניתן , לסמן אותו כבר כעת
  .זאת גם לאחר ההתקנה וכאשר נוצר הצורך

  
  

 #Cקבצים אלו הם קבצי העזרה של  , MSDN -בחלון הבא תשאלו האם להתקין את קבצי ה
Expressובדוגמאות הם בהחלט יעזרו לכם בדברי הסבר , ת גודלם וחשוב מאוד להתקינם למרו
  .במקום בו תזדקקו להםקוד בדיוק 

  
  
  

 SQL Serverלהתקנת 
2005 

להורדה והתקנה של 
 .קבצי העזרה
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  : החלון הבא מייד אחריו מציג את הסיכום 
  .וגודל המקום הנדרש בכונן הקשיח, מיקום ההתקנה, מה יותקן

  

  
  

הנקרא ריו חלון הבא אחמעבירה אותנו לההתקנה ותהליך מתחילה את  Installלחיצה על הלחצן 
"Download and Install Progress ",מציג את התקדמות ההתקנה ה:  
  

  
  
  
  
  

 .להתקנת התוכנה
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  :עם סיום ההתקנה יפתח חלון סיכום 

  
  

  . יום30חובה לבצע רישום לתוכנה בתוך : בחלון סיכום ההתקנה מופיעה הודעת אזהרה 
  .בנוסף מופיע קישור לביצוע הרישום

  .ה עצמתוכנהך האת הרישום ניתן לבצע גם לאחר מכן מתו
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   רישום התוכנה–שלב שלישי 
  . יום מרגע ההתקנה30רישום התוכנה חייב להתבצע בתוך 

   .Helpאו מתוך התוכנה עצמה מתפריט , ניתן לבצע אותו ישירות ממסך ההתקנה
  

  
  

לחיצה עליו מובילה לאתר אינטרנט שבו מתבצע , במסך סיכום ההתקנה מופיע קישור לרישום
  :הרישום

  

 .להתקנת התוכנה

במידה ויש לכם 
Passport כתובת  או

Email  שלHotmail.  
במידה ואין לכם 

Passport או כתובת 
Email של Hotmail.  
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ל " של מיקרוסופט יש להקליד את כתובת הדואPassportבמידה ונרשמתם בעבר ויש לכם 
   .Sign Inוללחוץ על הלחצן , המוכרת ואת הסיסמה

  . המופיע בצידו השמאלי של החלוןSign up Nowבמידה ואין לכם לחצו על הלחצן 
  :םהלחיצה תעביר אתכם לדף אחר בו תתבקשו להקליד את פרטיכם הרלבנטיי

  
  

מייד ל חוקית "ולרשום כתובת דוא, חובה למלא את כל השדות המעוטרים בכוכבית אדומה
  .לאחריו תקבלו דף עם קוד הרישום

  

  קוד הרישום
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  .)CTRL+C ( את קוד הרישום יש להעתיק
   .Help � Register Product יש לגשת לתפריט C# Express -מתוך ה

   .Complete Registrationאת הקוד וללחוץ על הלחצן ) CTRL+V(ולהדביק 
  

  
  
   
  
  
  

הדבקת קוד 
  .הרישום

 צילומי המסכים ואף שלבי ההתקנה יכולים להשתנות ממחשב: הערה 
 .אולם השינויים הם מינוריים בדרך כלל, גרסהמחשב או מגרסה ל



 11 

   C# Expressהכרות עם 
  

C# Expressתכונות שהופכות את תהליך הפיתוח  ככל כלי פיתוח מתקדם מסוגו מכיל מספר 
  .מציאה ותיקון תקלות, ואף עוזרות במניעה, מקלות על תהליך הכתיבה, לפשוט יותר

  
   :  מתבצעת מתוךC# Expressהפעלת 

Start �All Program �Microsoft Visual C# 2005 Express Edition 
  

  
  

  . התוכנית מבצעת בדיקות שונותם במהלכר דקותלערוך מספההפעלה הראשונה יכולה 
 :מסך הפתיחה שנקבל 

  

  

 C# Expressהרצת 
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  מסך הפתיחה
באמצעות מסך הפתיחה ניתן לפתוח  ,  ”Start Page“ מכונה C# Expressמסך הפתיחה של 
לגשת למאמרים מומלצים של  , ים קיימים שעבדנו עליהם בעברלפתוח פרויקט, פרויקטים חדשים

  .וללמוד על כלי הפיתוח עצמו, מיקרוסופט
 

  
  

  : ניתן להציג אותו מחדש באמצעות התפריט ,  נעלםStart Pageלעיתים קורה שמסך 
View -> Other Windows -> Start Page 

 

  

 Start Pageהצגת 
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  יםפרויקט
    

   .)Solution( "פיתרון "כונהעבודה המ מוגדרת יחידת C# Express - ב
  .פרויקט הוא יחידת פיתוח הקטנה ביותר, אחד או יותר) Project(מכיל פרויקט " פיתרון"ה

 שלכל אחד פרויקטים רב של רמורכב ממספ" פיתרון"בפתוח המתבצע בחברות וארגונים כל 
  . מוגדר במערכתמהם תפקיד 

  . אחד בלבדבשלב זה של חייכם המקצועיים אתם תעבדו עם פרויקט
  .ו מספר פרויקטים בתוכניות אותם הם יתרגלוב כבר ישלWSתלמידי 

   

  פתיחת פרויקט חדש
  

  :פרויקט חדש ניתן לפתוח במספר דרכים
 … Create -> Projectבוחרים  Recent Projectsבחלון ,  Start Page בחלון – 1
  

  
  
   .File -> New Project:  מהתפריט – 2

  
 CTRL+SHIFT+Nנית על  לחיצה בו זמ– 3

 
 
  
  

 פתיחת פרויקט חדש

 פתיחת פרויקט חדש
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   .New Project מובילים אותנו לחלון הנקרא שלושת הדרכים שהוזכרו לעיל
  ).מתוך מספר תבניות קיימות(בחלון זה ניתן לבחור את תבנית הפרויקט 
   . Console Applicationבשלב הראשון תבנית הפרויקטים תהיה 
  .בנוסף יש לבחור שם משמעותי לפרויקט

  

 
 

  . מייצרת את הפרויקטOKלחיצה על הלחצן 
ולכן חשוב  קורס לא ניתן יהיה לשחזר אותו בבמידה והמחש, בשלב זה הפרויקט נשמר בזיכרון

  .לשמור אותו בדיסק הקשיח
  :Save Project פותחת את החלון הנקרא Save Allלחיצה על 

 

  
  

 

 לפרויקט) משמעותי(מתן שם 

   Console Applicationתבנית 

Save All  

 Saveחלון
Project   

  שם הפרויקט

מיקום הפרויקט 
  בספרית הקבצים
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  .מרת את הפרויקט בדיסק בקשיח שוSaveלחיצה על הלחצן , מגדירים את מיקום הפרויקט

   .My Documents\Visual Studio 2005\Projectsמיקום ברירת המחדל של הפרויקט הוא 
  

  קבצי הפרויקט
  

  : חשוביםתהליך בניית הפרויקט ושמירתו בדיסק הקשיח מייצרים מספר קבצים
  . מגדיר את הפרויקטים הקשורים בוSolution -קובץ הגדרות ה : slnקובץ 
  .קובץ הפרויקט : csproj קובץ
   .Main המכיל את מחלקה בה מוגדרת השיטה הראשית #C - קובץ קוד ב : Program.csקובץ 

  .אולם מפאת חשיבותם הפחותה הם לא מוסברים, הפרויקט מכיל מספר קבצים נוספים
 

  פתיחת פרויקט קיים
פתוח פרויקטים לרוב נוצר צורך ל,  נפתח פרויקט חדשVisual Studioלא בכל פתיחה של 

  .קיימים על מנת להמשיך לפתח אותם או פשוט לצפות בקוד שכבר נכתב
  

  :פרויקט קיים ניתן לפתוח במספר דרכים
  
 . ופותחת את הפרויקטVisual Studioמפעילה את  slnלחיצה כפולה על קובץ  .1
 .… Open -> Project בוחרים Recent Projectsבחלון  , Start Pageבחלון  .2
  

  
  
  
  
  
  
  
  

 פתיחת פרויקט קיים
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 .File -> Open Project: מהתפריט  .3
  CTRL+SHIFT+Oלחיצה בו זמנית על  .4
  

   .sln -קובץ האשר באמצעותו נחפש את  פותחת חלון 2,3,4פתיחת הפרויקט על פי סעיפים 
   

  

 פתיחת פרויקט קיים
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  )Text Editor(עורך הטקסט 
  

  .רוב רובה של עבודת התכנות מתבצעת בעורך הטקסט
  

  
  

ביותר הקיימים " אנושיים"הוא מעורכי הטקסט המתקדמים וה Visual Studioעורך הטקסט של 
  .בעולם הפיתוח

  .יש לו יכולות רבות העוזרות למפתחים ומזרזות את תהליך כתיבת הפרויקטים
  .מאמר זה סוקר רק את החשובים שבהם

  
  . מופיעות בצבע כחול#Cהמילים השמורות של 

  .שמות הטיפוסים המוגדרים בתוכנית מופיעים בצבע ירוק
השינויים אינם נשמרים אוטומטית אלא יש לשמור אותם , כאשר מקלידים פקודות חדשות בקובץ

  :עורך הטקסט מסמן כוכבים ליד שמות הקבצים ששונו ואינם נשמרו , Saveבאמצעות 

  

  עורך הטקסט

  קובץ לא שמור

  שמות הטיפוסים
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צבעוניים דרך נוספת שעורך הטקסט מציג מידע שלא נשמר לדיסק הקשיח היא באמצעות פסים 

  .רך הטקסטבשול השמאלי של עו
  ,פס ירוק משמעותו קוד שנשמר

 .פס צהוב משמעותו קוד חדש שעדיין לא נשמר
  

  
  

   .CTRL + S או Saveשמירת הקובץ מתבצעת באמצעות הלחצן 
  

  ,)Indentation(ן  נכוריווחכדי שהקובץ יהיה קריא יש לשמור על 
 :הקודתקלות וקושי בהבנה של , קוד שנראה כמו בתמונה הבאה מזמין שגיאות

  

  
  
  
  
  
  
  
  
  
  

פקודות 
  שמורות

פקודות לא 
  שמורות



 19 

  
   .Edit -> Advanced -> Format Documentניתן לסדר את הקוד על ידי התפריט 

  

  
  
עורך הטקסט מעביר את סמן הכתיבה  , Enterבכל מקרה כאשר יורדים שורה באמצעות המקש 

  .כדאי לא לשנות זאת, למיקום המומלץ לתחילת השורה
  

  )IntlliSense(השלמת מילים אוטומטית 
 

שמות /שמות טיפוסים/כלי עזר מאוד שימושי אשר מציע להשלים בעצמו את המילים השמורות
  .משתנים בזמן ההקלדה

  

  
  

כדי לבחור מילה שהוא מציע ניתן , מנגנון זה מופעל אוטומטית בתחילת הקלדה
   .Enter או TABלהקליד 

   .CTRL+Spaceבמידה והוא לא מופיע ניתן להפעיל אותו ידנית באמצעות 

  קודסידור ה
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   Solution Explorer -חלון ה
  

Visual Studio אחד מהם הוא חלון ה, חשובים מגדירה מספר חלונות עזר - Solution 
Explorerהמספק מידע על תכולת ה - Solutionמחיקה או , הסרה, ומאפשר הוספה והפרויקטים

  .שינוי שם של קבצים
כברירת מחדל ,  Visual Studioשל  ממוקם בדרך כלל בצידו הימני Solution Explorer - חלון ה

, הוא אינו מוצג אלא מיוצג על ידי לשונית אשר עמידה עליה עם הסמן של העכבר פותחת אותו
ניתן לנעול , הוא נסגר אוטומטיתSolution Explorer -ברגע שהעכבר עוזב את שטח חלון ה

   .Solution Explorer -אותו על ידי סמל הנעץ הממוקם בראש חלון ה
  : סגורמצב

   
  

 View -> Solution Explorer: ניתן להציגה על ידי התפריט , במידה והלשונית אינה מופיעה 
  

  
  
  
  

   Solution Explorer -לשונית ה
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  :מצב פתוח

  
  
  

  צי הפרויקטקבב טיפול
  

למחוק , להסיר אותם מהפרויקט, במהלך תהליך הפיתוח נוצר הצורך להוסיף קבצים לפרויקט
  .אותם קליל או לשנות את שמם

  
   : Solution Explorer - באמצעות ההוספת קובץ

  לחיצה על הלחצן הימני של העכבר כאשר סמן העכבר עומד על שם הפרויקט בחירה 
   .Add New Item - פותחת את חלון ה , Add ->New Class - ב

  

   Solution Explorer - ה

 Solution -נעיצת ה
Explorer   

  קבצי הפרויקט

  הוספת קובץ חדש
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בוחרים שם  , classהנקראת ) Template( בוחרים תבנית קובץ  Add New Item -בחלון ה
   .Addים על הלחצן משמעותי לקובץ ולוחצ

  

  
  

 או לחיצה בו זמנית Project -> Add Class: את אותו התהליך ניתן לבצע באמצעות התפריט 
  :Shift + Alt + Cעל 

 

 
  

  בחירת תבנית

  בחירת שם לקובץ החדש

  הוספת קובץ חדש
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   :Solution Explorer -הקובץ החדש התווסף ל

  
  

   .Text Editor - לחיצה כפולה עם סמן העכבר פותחת אותו ב
  
  

  הרצה
  :גם קומפילציה ניתן לבצע במספר דרכים,  קומפילציהבצענעם סיום ההקלדה 

  .Build->Build Solution: מהתפריט  .1

  
  .Solution Explorer -המחלון  .2

  
  

  הקובץ חדש

  ביצוע קומפילציה

  ביצוע קומפילציה



 24 

  .F6לחיצה על  .3
  

  : מודיע לנו שהקומפילציה הצליחהVisual Studioבמידה ולא היו שגיאות 

  
  .ההודעה מופיעה בתחתית החלון מצד שמאל

  
  :הם מסומנות בקו מזוגזג בצבע אדום, ניתן לגלותם כבר במהלך ההקלדהבמידה ויש שגיאות 

  
  
  

   .Error List - מופיעות בחלון הוהאזהרות שגיאות הקומפילציה 
  . מציג את השגיאות וההערות שנתגלו במהלך הקומפילציה ומפרט אותןError List - חלון ה

  

  
  
  
  
  
  
  
  
  
  

   MSDNגישה לעזרה 

 Error List - חלון ה

  מספר השגיאות

  תיאור השגיאות  מספר האזהרות

הקובץ בו נתגלו 
  מספר השורה   .השגיאות 

  המיקום בשורה

  סימון שגיאה

הקומפילציה 
  הצליחה


